For RIOTOUS to function correctly there are a few requirements for the controller used and the ESP8266 module

The RIOTOUS Framework requires a specific version of the ESP8266 firmware (SDK 1.5.4 and AT so do remember to either program the ESP8266 module following this guide or purchase a pre-configured module from here. Programming ESP8266 modules is easier than it may seem (especially with the programming package that can be obtained from the download page).